[testsuite, i386] Require avx in gcc.target/i386/pr59501-*.c

Rainer Orth ro@CeBiTec.Uni-Bielefeld.DE
Mon Jan 6 13:32:00 GMT 2014


The new gcc.target/i386/pr59501-*.c tests were FAILing on Solaris 9/x86
with Sun as:

FAIL: gcc.target/i386/pr59501-1.c (test for excess errors)

Excess errors:
Assembler: pr59501-1.c
        "/var/tmp//cclOtnd2.s", line 28 : Illegal mnemonic
        "/var/tmp//cclOtnd2.s", line 28 : Syntax error

and many more.  Obviously they need an assembler with avx support.  Fixed
by requiring an avx effective-target.

Tested on i386-pc-solaris2.9, i386-pc-solaris2.10, and
x86_64-unknown-linux-gnu; installed on mainline.

	Rainer


2014-01-03  Rainer Orth  <ro@CeBiTec.Uni-Bielefeld.DE>

	* gcc.target/i386/pr59501-1.c: Require avx effective target.
	* gcc.target/i386/pr59501-2.c: Likewise.
	* gcc.target/i386/pr59501-3.c: Likewise.
	* gcc.target/i386/pr59501-4.c: Likewise.
	* gcc.target/i386/pr59501-5.c: Likewise.
	* gcc.target/i386/pr59501-6.c: Likewise.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: testsuite-i386-pr59501-avx.patch
Type: text/x-patch
Size: 2524 bytes
Desc: not available
URL: <http://gcc.gnu.org/pipermail/gcc-patches/attachments/20140106/dfd04dce/attachment.bin>
-------------- next part --------------

-- 
-----------------------------------------------------------------------------
Rainer Orth, Center for Biotechnology, Bielefeld University


More information about the Gcc-patches mailing list