[AArch64] [1/4 Fix vtbx1] Allow signed and unsigned versions of intrinsics to coexist.

James Greenhalgh james.greenhalgh@arm.com
Fri Nov 22 15:56:00 GMT 2013


Hi,

One oversight in the design for the AArch64 Simd Builtins type
building foo I put in this week is that you cannot have both
signed and unsigned versions of the same builtin.

Although I solved the problem at a user level by appending a "type"
string to the builtin name, I didn't manage to solve it internally
for the aarch64_builtins enum.

This patch fixes that by appending the TYPE parameter to each
of these enum names.

Thus:
  AARCH64_SIMD_BUILTIN_my_builtin
Becomes:
  AARCH64_SIMD_BUILTIN_BINOP_my_builtin

And if we also wanted an unsigned variant we would see:
  AARCH64_SIMD_BUILTIN_BINOP_U_my_builtin

Regression tested on aarch64-none-elf with no regressions.

OK?

Thanks,
James

---
gcc/

2013-11-22  James Greenhalgh  <james.greenhalgh@arm.com>

	* config/aarch64/aarch64-builtins.c
	(VAR1): Use new naming scheme for aarch64_builtins.
	(aarch64_builtin_vectorized_function): Use new
	aarch64_builtins names.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-AArch64-1-4-Fix-vtbx1-Allow-signed-and-unsigned-vers.patch
Type: text/x-patch
Size: 4486 bytes
Desc: not available
URL: <http://gcc.gnu.org/pipermail/gcc-patches/attachments/20131122/6fdbe1e4/attachment.bin>


More information about the Gcc-patches mailing list