[PATCH] rs6000: Group processor types

David Edelsohn dje.gcc@gmail.com
Fri May 31 15:19:00 GMT 2013


On Fri, May 31, 2013 at 3:34 AM, Segher Boessenkool
<segher@kernel.crashing.org> wrote:
> Long lines like this define_attr are hard to read, and patches to
> them are hard to read and apply.
>
> Bootstrapped and tested on powerpc64-linux --enable-languages=c,c++,fortran
> --disable-libsanitizer, -m64,-m32,-m32/-mpowerpc64, no regressions.  Okay
> to apply?
>
>
> 2013-05-31  Segher Boessenkool  <segher@kernel.crashing.org>
>
> gcc/
>         * config/rs6000/rs6000-opts.h (enum processor_type): Reorder.
>         * config/rs6000/rs6000.md: (cpu): Reorder.  Split long line.
>         Fix comment.

Okay, but if you are going to split the lines and group the
processors, I would place Motorola ppc7xx/ppc7xxx on a separate line.

> +(define_attr "cpu"
> +  "ppc601,ppc603,ppc604,ppc604e,ppc620,ppc630,
+ ppc750,ppc7400,ppc7450,
> +   ppc403,ppc405,ppc440,ppc476,
> +   ppc8540,ppc8548,ppce300c2,ppce300c3,ppce500mc,ppce500mc64,ppce5500,ppce6500,
> +   power4,power5,power6,power7,power8,
> +   rs64a,mpccore,cell,ppca2,titan"

I don't have any particularly good grouping for the last 5, although
rs64a and ppca2 are IBM while mpccore is Motorola.

- David



More information about the Gcc-patches mailing list