[Fortran-dev][Patch, committed] Add version field, rename "size" to "elem_len"
Sun Mar 31 10:35:00 GMT 2013
I have committed (Rev.197282) the attached patch as obvious to the
It add the "int version" field to the array constructor and moved "size"
up, renaming it to "elem_len" and changing its type to size_t (which is
effectively the same). This brings the array descriptor a bit closer to
the one of TS29113.
Additionally, the patch now sets version to 1 in some (few) cases, e.g.
allocatables with SAVE attribute.
PS: The next step is to fix a bunch of test-suite failures; some old,
some due to the merge. The next bigger step is to remove "offset", to
split the dtype - and set version, elem_len, rank and type fields.
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 5181 bytes
Desc: not available
More information about the Gcc-patches