[patch] Unified debug dump function names.

Lawrence Crowl crowl@googlers.com
Mon Mar 25 17:20:00 GMT 2013


On 3/25/13, Richard Biener <richard.guenther@gmail.com> wrote:
> You add a not used new interface.  What for?

So that people can use it.

> For use from gdb only?

No, for use from both gdb and internally.  It is often that folks add
dumps in various places while developing/debugging.  These functions
support that effort without having to hunt down the name.

> In which case it should be debug (), not dump ().

I will use whatever name you wish, but I would have preferred that
we addressed naming issues when we published the plan, not after
I've done the implementation.  What name do you wish?

-- 
Lawrence Crowl



More information about the Gcc-patches mailing list