[patch] set MULTIARCH_DIRNAME for multilib architectures

Bernhard Reutner-Fischer rep.dot.nop@gmail.com
Thu Jun 13 06:42:00 GMT 2013


On 12 June 2013 20:20:50 Richard Sandiford <rdsandiford@googlemail.com> wrote:
> Matthias Klose <doko@ubuntu.com> writes:
> > Index: config/mips/t-linux64
> > ===================================================================
> > --- config/mips/t-linux64	(revision 200012)
> > +++ config/mips/t-linux64	(working copy)
> > @@ -24,3 +24,13 @@
> >  	../lib32$(call 
> if_multiarch,:mips64$(MIPS_EL)-linux-gnuabin32$(MIPS_SOFT)) \
> >  	../lib$(call if_multiarch,:mips$(MIPS_EL)-linux-gnu$(MIPS_SOFT)) \
> >  	../lib64$(call if_multiarch,:mips64$(MIPS_EL)-linux-gnuabi64$(MIPS_SOFT))
> > +
> > +ifneq (,$(findstring abin32,$(target)))
> > +MULTIARCH_DIRNAME = $(call 
> if_multiarch,mips64$(MIPS_EL)-linux-gnuabin32$(MIPS_SOFT))
> > +else
> > +ifneq (,$(findstring abi64,$(target)))
> > +MULTIARCH_DIRNAME = $(call 
> if_multiarch,mips64$(MIPS_EL)-linux-gnuabi64$(MIPS_SOFT))
> > +else
> > +MULTIARCH_DIRNAME = $(call 
> if_multiarch,mips$(MIPS_EL)-linux-gnu$(MIPS_SOFT))
> > +endif
> > +endif
>
> findstring seems a bit fragile for a full triple.  I think it would
> be better to have something similar to the current MIPS_SOFT definition:
>
> MIPS_SOFT = $(if $(strip $(filter MASK_SOFT_FLOAT_ABI, 
> $(target_cpu_default)) $(filter soft, $(with_float))),soft)
>
> but for ABIs.  It could then also take with_abi into account.
> Maybe something like:
>
> MIPS_ABI = $(or $(with_abi), \
>                 $(if $(filter MIPS_ABI_DEFAULT=ABI_N32, \
> 			      $(target_cpu_default)), n32), \
>                 o32)
>
> (completely untested).

Bikeshedding:
Doko would know, but ISTR that $(or) did not exist in make-3.80 which is 
currently the minimum prerequisite, fwiw.


Sent with AquaMail for Android
http://www.aqua-mail.com




More information about the Gcc-patches mailing list