[PATCH] Fix maybe_lower_iteration_bound leak (PR middle-end/56461)

Jeff Law law@redhat.com
Wed Feb 27 22:00:00 GMT 2013


On 02/27/2013 01:19 PM, Jakub Jelinek wrote:
> Hi!
>
> This function leaks the not_executed_last_iteration pointer set.
>
> Fixed thusly, bootstrapped/regtested on x86_64-linux and i686-linux, ok for
> trunk?
>
> 2013-02-27  Jakub Jelinek  <jakub@redhat.com>
>
> 	PR middle-end/56461
> 	* tree-ssa-loop-niter.c (maybe_lower_iteration_bound): Call
> 	pointer_set_destroy on not_executed_last_iteration.
OK.
Jeff



More information about the Gcc-patches mailing list