[PATCH] Disable libsanitizer before darwin10

Alexander Potapenko glider@google.com
Mon Feb 11 16:06:00 GMT 2013


For the record, ASan never claimed darwin9 support and isn't going to
support darwin9 in the future, so it should be fine to disable
building ASan on this platform.

On Mon, Feb 11, 2013 at 7:55 PM, Jack Howarth <howarth@bromo.med.uc.edu> wrote:
>   Iain Sandoe discovered that on intel darwin9, the asan testsuite suffers hundreds of
> failures due to the absence of dispatch calls (Grand Central Dispatch) prior to darwin10.
> The attached patch disables building libsanitizer on darwin8 and darwin9 until upstream
> decides to support the earlier darwin releases. Bootstrap and regression tested on
> x86_64-apple-darwin12. Okay for gcc trunk?
>          Jack



--
Alexander Potapenko
Software Engineer
Google Moscow



More information about the Gcc-patches mailing list