C++ PATCH: Use VAR_P instead of direct TREE_CODE (t) == VAR_DECL

Gabriel Dos Reis gdr@integrable-solutions.net
Tue Apr 2 10:03:00 GMT 2013


On Tue, Apr 2, 2013 at 4:44 AM, Paolo Carlini <paolo.carlini@oracle.com> wrote:
> Hi,
>
> On 04/02/2013 11:30 AM, Gabriel Dos Reis wrote:
>
> []
>
>> Sorry for chiming in late - but VAR_P loses the fact that we are checking
>> for a decl ... VAR_DECL_P would be more like following existing practice
>> (otherwise we can shorten VAR_OR_FUNCTION_DECL_P to
>> VAR_OR_FUNCTION_P for example).  As for further cleanups we seem
>> to have a few IS_... macros as well (one even IS_..._P).
>>
>> Richard.
>> If we are checking for a VAR, we necessarily checking for a VAR decl..
>>
>> The purpose of the macro is make the predicates more readable.
>> I would not mind having VAR_OR_FUNCTION_P instead.
>>
>> Yes, we should get rid of the IS_.
>
> For example we have:
>
> #define IS_OVERLOAD_TYPE(T) TAGGED_TYPE_P (T)
>
> shall we keep only one? The below - untested - gets rid of the latter and
> renames the former to OVERLOAD_TYPE_P.
>
> Paolo.
>
> /////////////////
>
>

That is a sensible choice.  OK, it passes testing.



More information about the Gcc-patches mailing list