[PATCH v2, middle-end]: Introduce TARGET_REJECT_COMBINED_INSN target hook

Georg-Johann Lay avr@gjlay.de
Sat Aug 25 19:02:00 GMT 2012


Oleg Endo schrieb:
> On Sat, 2012-08-25 at 20:25 +0200, Georg-Johann Lay wrote:
> 
>> BTW: while I typed the lines above I find it more natural to
>> return "true" for good patterns and "false" for bad patterns
>> and not vice versa.  But that's just a matter of taste.
> 
> But then that won't fit with 'reject_combined_insn'.
> Reject? -> return 'true' for bad pattern that is to be rejected.
> Maybe if the hook was called something like
> 'legitimate_combined_insn'...

Ya, that would be a reasonable name and fit into already existing
targetm.legitimate_foo namings.

Johann



More information about the Gcc-patches mailing list