[rs6000, spu] Add vec_perm named pattern
Richard Henderson
rth@redhat.com
Fri Oct 14 22:39:00 GMT 2011
On 10/14/2011 12:53 PM, Michael Meissner wrote:
> I would rather change altivec_vperm_<mode> to use the new name (and also
> altivec_vperm_<mode>_uns). But I can live with a wrapper function for now.
As I said, I'm leaving the cleanup of the old patterns to port maintainers.
> If we are adding permute options, can we please get the vectorizer to use
> optabs instead of using the targetm.vectorize.builtin_vec_perm hook? It has
> always struck me as a sore thumb that we have a hook that needs to return a
> builtin function decl (targetm.vectorize.builtin_mask_for_load also).
That's exactly what I've been working on today.
r~
More information about the Gcc-patches
mailing list