[PATCH] [mingw] fix typo: s/_REENTRANCE/_REENTRANT/

Ozkan Sezer sezeroz@gmail.com
Mon Oct 3 15:07:00 GMT 2011


On Mon, Oct 3, 2011 at 5:56 PM, Kai Tietz <ktietz70@googlemail.com> wrote:
> 2011/10/3 Ozkan Sezer <sezeroz@gmail.com>:
>> PING?
>>
>> On Thu, Sep 22, 2011 at 2:28 PM, Ozkan Sezer <sezeroz@gmail.com> wrote:
>>> Hi:
>>>
>>> Unless I'm missing something, the mingw CPP_SPEC changes introduced in
>>> r171833 have a typo: -D_REENTRANCE should read -D_REENTRANT . Patchlet
>>> below.  Please review, and apply if it's OK.
>>>
>>>
>>> config/i386/mingw-w64.h (CPP_SPEC): Rename _REENTRANCE to _REENTRANT.
>>> config/i386/mingw32.h (CPP_SPEC): Likewise.
>>>
>>> Index: config/i386/mingw-w64.h
>>> ===================================================================
>>> --- config/i386/mingw-w64.h     (revision 171833)
>>> +++ config/i386/mingw-w64.h     (working copy)
>>> @@ -25,8 +25,8 @@
>>>  #undef CPP_SPEC
>>>  #define CPP_SPEC "%{posix:-D_POSIX_SOURCE} %{mthreads:-D_MT} " \
>>>                 "%{municode:-DUNICODE} " \
>>> -                "%{" SPEC_PTHREAD1 ":-D_REENTRANCE} " \
>>> -                "%{" SPEC_PTHREAD2 ":-U_REENTRANCE} "
>>> +                "%{" SPEC_PTHREAD1 ":-D_REENTRANT} " \
>>> +                "%{" SPEC_PTHREAD2 ":-U_REENTRANT} "
>>>
>>>  #undef STARTFILE_SPEC
>>>  #define STARTFILE_SPEC "%{shared|mdll:dllcrt2%O%s} \
>>> Index: config/i386/mingw32.h
>>> ===================================================================
>>> --- config/i386/mingw32.h       (revision 177789)
>>> +++ config/i386/mingw32.h       (working copy)
>>> @@ -87,7 +87,7 @@
>>>
>>>  #undef CPP_SPEC
>>>  #define CPP_SPEC "%{posix:-D_POSIX_SOURCE} %{mthreads:-D_MT} " \
>>> -                "%{" SPEC_PTHREAD1 ":-D_REENTRANCE} " \
>>> +                "%{" SPEC_PTHREAD1 ":-D_REENTRANT} " \
>>>                 "%{" SPEC_PTHREAD2 ": } "
>>>
>>>  /* For Windows applications, include more libraries, but always include
>>>
>>>
>>> --
>>> O.S.
>>>
>
> Patch is ok together with a ChangeLog.
>
> Thanks,
> Kai
>

Here it is again with a changelog entry (Thought that I included one
the first time..)  Thanks.

	* config/i386/mingw-w64.h (CPP_SPEC): Rename _REENTRANCE to _REENTRANT.
	* config/i386/mingw32.h (CPP_SPEC): Likewise.

Index: config/i386/mingw-w64.h
===================================================================
--- config/i386/mingw-w64.h	(revision 171833)
+++ config/i386/mingw-w64.h	(working copy)
@@ -25,8 +25,8 @@
 #undef CPP_SPEC
 #define CPP_SPEC "%{posix:-D_POSIX_SOURCE} %{mthreads:-D_MT} " \
 		 "%{municode:-DUNICODE} " \
-		 "%{" SPEC_PTHREAD1 ":-D_REENTRANCE} " \
-		 "%{" SPEC_PTHREAD2 ":-U_REENTRANCE} "
+		 "%{" SPEC_PTHREAD1 ":-D_REENTRANT} " \
+		 "%{" SPEC_PTHREAD2 ":-U_REENTRANT} "

 #undef STARTFILE_SPEC
 #define STARTFILE_SPEC "%{shared|mdll:dllcrt2%O%s} \
Index: config/i386/mingw32.h
===================================================================
--- config/i386/mingw32.h	(revision 177789)
+++ config/i386/mingw32.h	(working copy)
@@ -87,7 +87,7 @@

 #undef CPP_SPEC
 #define CPP_SPEC "%{posix:-D_POSIX_SOURCE} %{mthreads:-D_MT} " \
-		 "%{" SPEC_PTHREAD1 ":-D_REENTRANCE} " \
+		 "%{" SPEC_PTHREAD1 ":-D_REENTRANT} " \
 		 "%{" SPEC_PTHREAD2 ": } "

 /* For Windows applications, include more libraries, but always include

--
O.S.



More information about the Gcc-patches mailing list