[PATCH][RFC][1/2] Bitfield lowering, add BIT_FIELD_EXPR

Eric Botcazou ebotcazou@adacore.com
Thu Jun 16 18:10:00 GMT 2011


> I think this would be clearer with a name like DEPOSIT_EXPR,
> similar to the ia64 deposit instruction.

ia64's demise wasn't entirely undeserved then.  IMO the descriptive power of
DEPOSIT_EXPR is almost null.  BIT_FIELD_MODIFY_EXPR or something like this.

-- 
Eric Botcazou



More information about the Gcc-patches mailing list