CFT: Move unwinder to toplevel libgcc

Steve Ellcey sje@cup.hp.com
Thu Jul 7 15:53:00 GMT 2011


On Thu, 2011-07-07 at 15:08 +0200, Rainer Orth wrote:
> Tristan Gingold <gingold@adacore.com> writes:
> 
> >> Otherwise, the patch is unchanged from the original submission:
> >> 
> >> 	[build] Move unwinder to toplevel libgcc
> >> 	http://gcc.gnu.org/ml/gcc-patches/2011-06/msg01452.html
> >> 
> >> Unfortunately, it hasn't seen much comment.  I'm now looking for testers
> >> especially on platforms with more change and approval of those parts:
> >> 
> >> * Several IA-64 targets:
> >> 
> >> 	ia64*-*-linux*
> >>        ia64*-*-hpux*
> >>        ia64-hp-*vms*
> >
> > For ia64-hp-vms, consider your patch approved if the parts for ia64 are.
> > In case of break, I will fix them.
> 
> In that case, perhaps Steve could have a look?  I'd finally like to make
> some progress on this patch.
> 
> Thanks.
>         Rainer

I just tried builds on ia64 linux and HP-UX and both builds failed.  I
am re-trying the HP-UX build with --with-system-libunwind to see if that
changes things but that should be the default on IA64 HP-UX.

On Linux (debian) the build stopped with:

/test/big-foot1/gcc/nightly/gcc-ia64-debian-linux-gnu-trunk/ia64-debian-linux-gnu/bin/ranlib libgcov.a
make[3]: *** No rule to make target
`/test/big-foot1/gcc/nightly/src/trunk/libgcc/unwind-sjlj.c', needed by
`unwind-sjlj.o'.  Stop.
make[3]: Leaving directory
`/test/big-foot1/gcc/nightly/build-ia64-debian-linux-gnu-trunk/obj_gcc/ia64-debian-linux-gnu/libgcc'
make[2]: *** [all-stage1-target-libgcc] Error 2
make[2]: Leaving directory
`/test/big-foot1/gcc/nightly/build-ia64-debian-linux-gnu-trunk/obj_gcc'
make[1]: *** [stage1-bubble] Error 2
make[1]: Leaving directory
`/test/big-foot1/gcc/nightly/build-ia64-debian-linux-gnu-trunk/obj_gcc'
make: *** [bootstrap] Error 2


The patch appeared to install correctly into my source tree and I ran autoreconf to regenerate the
configure files.  It looks like patch didn't handle the unwind files that moved.  I will try doing
that by hand and see if that fixes things.

Steve Ellcey
sje@cup.hp.com



More information about the Gcc-patches mailing list