[PATCH] Tweak var-tracking to better handle x86-64 lea insns

Richard Henderson rth@redhat.com
Tue Mar 30 15:37:00 GMT 2010


On 03/29/2010 11:27 AM, Jakub Jelinek wrote:
> +/* Helper for adjust_mems.  Return 1 if *loc is unsuitable for
> +   transformation of wider mode arithmetics to narrower mode,
> +   -1 if it is suitable and subexpressions shouldn't be
> +   traversed and 0 if it is suitable and subexpressions should
> +   be traversed.  */
> +
> +static int
> +use_narrower_mode_p (rtx *loc, void *data)

Generally ok.  I'd like to find a better name for this function,
since "_p" suggests that a true return means suitable.  How about
just "use_narrower_mode_test" and mention in the function comment
that it is called via for_each_rtx?


r~



More information about the Gcc-patches mailing list