[PATCH] Don't emit certain artificial names into DW_AT_name in debug info

Jakub Jelinek jakub@redhat.com
Fri Jul 23 12:19:00 GMT 2010


On Fri, Jul 23, 2010 at 02:08:58PM +0200, Richard Guenther wrote:
> On Fri, 23 Jul 2010, Jakub Jelinek wrote:
> Hmm - looking again I see
> 
> /* Nonzero for a given ..._DECL node means that the name of this node 
> should
>    be ignored for symbolic debug purposes.  Moreover, for a FUNCTION_DECL,
>    the body of the function should also be ignored.  */
> #define DECL_IGNORED_P(NODE) \
>   (DECL_COMMON_CHECK (NODE)->decl_common.ignored_flag)

DECL_IGNORED_P means it is ignored completely for debug info purposes.
For the ones touched by this patch, we must not do this, we really need to
emit the DIEs as they are referenced from other places, we need to track
their location (DECL_IGNORED_P decls aren't tracked at all e.g. by
var-tracking), etc.
We want to emit them as DW_AT_artificial without DW_AT_name, as the name
is made up.

	Jakub



More information about the Gcc-patches mailing list