PATCH: ARM va_list

Andrew Pinski pinskia@gmail.com
Wed Jan 14 00:40:00 GMT 2009


On Tue, Jan 13, 2009 at 4:30 PM, Paul Brook <paul@codesourcery.com> wrote:
>> I guess it's hard to call this a regression, but the sooner we fix
>> this ABI breakage, the less pain we'll have, and this is an
>> ARM-specific fix.  Is an ARM maintainers willing to grant
>> dispensation?
>
> Are we planning on breaking the libstdc++ ABI any time soon (i.e. gcc4.5)?

What what putting this under -fabi-version=3 (I think that is the
current+1 version)?

And when we break the libstdc++ ABI, we break the normal C++ ABI also ...

Thanks,
Andrew Pinski



More information about the Gcc-patches mailing list