PATCH: gengtype-lex.l warning

Kaveh R. Ghazi ghazi@caip.rutgers.edu
Tue Jan 6 19:25:00 GMT 2009


From: "Joseph S. Myers" <joseph@codesourcery.com>

> Have the flex maintainers fixed the general class of problems with the
> recent flex release series I described in
> <http://gcc.gnu.org/ml/gcc/2007-01/msg00884.html>?

I don't know.  However I've successfully built GCC from svn on cfarm boxes 
containing flex-2.5.31 and 2.5.33.  So regardless of whether the m4 mangling 
issue is fixed in general, it doesn't seem to affect *our* lex files.

There is a claim here:
http://gcc.gnu.org/ml/gcc/2007-01/msg00874.html

that flex-2.5.33 produces signed/unsigned warnings, but I don't see that. 
(It may be that the distribution I use fixed things locally.)

        --Kaveh



More information about the Gcc-patches mailing list