PATCH: gengtype-lex.l warning

Joseph S. Myers joseph@codesourcery.com
Tue Jan 6 18:50:00 GMT 2009


On Tue, 6 Jan 2009, Tom Tromey wrote:

> >>>>> "Ben" == Ben Elliston <bje@au1.ibm.com> writes:
> 
> >> Are we at or close to being able to remove the -Wno-error from
> >> gengtype-lex.o ?
> 
> Ben> Not quite.  On my build system, we have flex 2.5.4 installed.  This
> Ben> version still generates code with warnings.  On my laptop, I have 2.5.35
> Ben> installed, which generates none.  Guess we need to wait a little longer.
> 
> According to the flex web site, 2.5.35 was released nearly a year ago.
> 
> 2.5.33 was released nearly 2 years ago.  If that version generates
> warning-free code, then maybe we could just bump the minimum required
> version to 2.5.33.

Have the flex maintainers fixed the general class of problems with the 
recent flex release series I described in 
<http://gcc.gnu.org/ml/gcc/2007-01/msg00884.html>?

-- 
Joseph S. Myers
joseph@codesourcery.com



More information about the Gcc-patches mailing list