PATCH: gengtype-lex.l warning

Tom Tromey tromey@redhat.com
Mon Jan 5 18:22:00 GMT 2009


>>>>> "Ben" == Ben Elliston <bje@au1.ibm.com> writes:

Ben> This can be suppressed by defining YY_NO_INPUT in the C preamble section
Ben> of the flex file.  This should not cause any problems for earlier
Ben> versions that do not conditionally compile the input function based on
Ben> the value of YY_NO_INPUT (this is only hypothetical; all the versions of
Ben> flex, new and old, that I tried all support this).

install.texi says that flex 2.5.4 is the minimum required version, so
you don't have to worry about anything before that.  So, if you tried
that version, you're probably safe.

Tom



More information about the Gcc-patches mailing list