[PATCH][ARM] Support arm-android-eabi

Doug Kwan (關振德) dougkwan@google.com
Mon Jul 14 21:38:00 GMT 2008


This is the version that got checked in.  I renamed the macros so
according to Mark's suggestion and I did the same to the Android spec
marcos.

-Doug

2008-07-14  Doug Kwan  <dougkwan@google.com>

	* config.gcc (arm*-*-eabi*): Include arm/eabi.h and use
	additional option file arm/eabi.opt.
	* config/arm/eabi.h (File): New configuration file for EABI targets.
	* config/arm/elf.h (SUBTARGET_EXTRA_SPECS): Add
	SUBSUBTARGET_EXTRA_SPECS.
	(SUBSUBTARGET_EXTRA_SPECS): Provide empty default.
	* config/arm/unknown-elf.h (UNKNOWN_ELF_STARTFILE_SPEC): Renamed
	from STARTFILE_SPEC so that it can be referenced in an override.
	(STARTFILE_SPEC): Use UNKNOWN_ELF_STARTFILE_SPEC.
	(UNKNOWN_ELF_ENDFILE_SPEC): Renamed from ENDFILE_SPEC so that it
	can be referenced in an override.
	(ENDFILE_SPEC): Use UNKNOWN_ELF_ENDFILE_SPEC.
	* config/arm/bpabi.h (BPABI_LINK_SPEC): Renamed from LINK_SPEC
	so that it can be referenced in an override.
	(LINK_SPEC): Use BPABI_LINK_SPEC.
	* config/arm/eabi.opt (File): New.


2008/7/14 Doug Kwan (關振德) <dougkwan@google.com>:
> Thanks for approving.  I picked the naming convention from the rs6000
> port you pointed to me earlier but I have no perference one way or
> another.
>
> -Doug
>
> 2008/7/14 Mark Mitchell <mark@codesourcery.com>:
>> Doug Kwan (關振德) wrote:
>>
>>> - LINK_SPEC, STARTFILE_SPEC and ENDFILE_SPEC use default for
>>> non-Android targets defined in header earlier in the inclusion chain
>>> (bpabi.h and unknown-elf.h)
>>
>> Great.  I think this is OK.  However, I would prefer the spelling
>> BPABI_LINK_SPEC to LINK_BPBAI_SPEC, as I suggested earlier.  (And, similarly
>> for the UNKNOWN_ELF specs.)  That's more like English ("the BPBABI link
>> specification") and more like OO notation ("BPABI::LINK_SPEC" or
>> "BPABI.LINK_SPEC").
>>
>> Please make that change, and check it in again...
>>
>> Thanks,
>>
>> --
>> Mark Mitchell
>> CodeSourcery
>> mark@codesourcery.com
>> (650) 331-3385 x713
>>
>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: patch.txt
URL: <http://gcc.gnu.org/pipermail/gcc-patches/attachments/20080714/deaa0c79/attachment.txt>


More information about the Gcc-patches mailing list