[patch] [tuples] convert pass_lower_vector and pass_lower_vector_ssa

Diego Novillo dnovillo@google.com
Wed Jan 30 10:03:00 GMT 2008


On 01/29/08 11:01, Rafael Espindola wrote:

> 2008-01-29  Rafael Espindola  <espindola@google.com>
>   * Makefile.in (tree-complex.o): Uncomment gt-tree-vect-generic.h.
>    (GTFILES): Add tree-vect-generic.c.
>   * passes.c (init_optimization_passes): Enable pass_lower_vector.
>   * tree-vect-generic.c: uncomment all the file.
>     (elem_op_func): Use gimple_stmt_iterator instead of block_stmt_iterator.
>     (tree_vec_extract): Likewise. Rename bsi to gsi.
>     (do_unop): Likewise.
>     (do_binop): Likewise.
>     (do_plus_minus): Likewise.
>     (do_negate): Likewise.
>     (expand_vector_piecewise): Likewise.
>     (expand_vector_parallel): Likewise.
>     (expand_vector_addition): Likewise.
>     (expand_vector_operation): Likewise. Remove "tree rhs" param. Add
> "gimple assign" param. Use gimple_assign_rhs1|2 instead of
> TREE_OPERAND.
>    (expand_vector_operations_1): Use gimple_stmt_iterator instead of
> block_stmt_iterator. Rename bsi to gsi. Use gsi_stmt instead of
> bsi_stmt. Use gimple_assign_* instead of GIMPLE_STMT_OPERAND. Use
> gimple_assign_set_rhs_from_tree instead of setting *p_rhs.
>    (gate_expand_vector_operations): Use gimple_stmt_iterator instead
> of block_stmt_iterator. Use gsi_* instead of bsi_*
>     (pass_lower_vector): flip works_with_tuples_p
>     (pass_lower_vector_ssa) flip works_with_tuples_p

OK.

In general, you can shorten CL entries for most things to say 'file.c: 
Convert to tuples.'  Though your description is certainly fine.  I tend 
to add more details when I've made other non-mechanical changes to the file.

The formatting of the ChangeLog entries is mis-indented.  See how other 
entries are in ChangeLog.tuples.


Thanks.  Diego.



More information about the Gcc-patches mailing list