[PATCH, testsuite]: Fix logic error in comment

Janis Johnson janis187@us.ibm.com
Wed Sep 12 03:48:00 GMT 2007

On Wed, 2007-09-12 at 10:40 +1000, Ben Elliston wrote:
> On Tue, 2007-09-11 at 18:22 +0300, Dorit Nuzman wrote:
> > you are right, the comment indeed doesn't match the name of the function.
> > Looking at the implemenation of the function, I see that we return 0 by
> > default (i.e. claiming that all targets support vector comparison of
> > doubles). I'd think we should return 1 by default. By the way, another
> > alternative is to invert the name of the function and keyword (to match the
> > comment and current default implementation). (By the way, do you happen to
> > know if this keyword is currently used anywhere?)
> I grepped the whole testsuite directory and could not find a single test
> case that uses this proc.  Therefore, I think the best course of action
> would be to just remove it.  Janis, would that be okay?



More information about the Gcc-patches mailing list