PATCH: 4.3 bootstrap broken when configured as i386-linux

Andreas Schwab schwab@suse.de
Mon Mar 26 19:00:00 GMT 2007


"H. J. Lu" <hjl@lucon.org> writes:

> On Mon, Mar 26, 2007 at 08:00:11PM +0200, Andreas Schwab wrote:
>> "Michael Meissner" <michael.meissner@amd.com> writes:
>> 
>> > Rather than using AC_CANONICAL and friends, a simpler patch follows.  Any
>> > comments on the patch, particularly from the libgcc maintainers?
>> 
>> libgcc is a target library, it should use $host, not $target.
>> 
>
> There are
>
> AC_CANONICAL_SYSTEM
> ...
> case "$target" in
>   powerpc*-*-*gnu* | \ 
>   sparc*-*-linux* | \ 
>   s390*-*-linux* | \ 
>
> in libstdc++-v3/configure.ac. Is that wrong?

It is obsolete.

Andreas.

-- 
Andreas Schwab, SuSE Labs, schwab@suse.de
SuSE Linux Products GmbH, Maxfeldstraße 5, 90409 Nürnberg, Germany
PGP key fingerprint = 58CA 54C7 6D53 942B 1756  01D3 44D5 214B 8276 4ED5
"And now for something completely different."



More information about the Gcc-patches mailing list