[autovect] [patch] Make store motion use alias oracle

Ian Lance Taylor iant@google.com
Wed Mar 14 14:32:00 GMT 2007

Revital1 Eres <ERES@il.ibm.com> writes:

> +/* Return true if STMT may have certain side effects
> +   and thus ifcvt can not be applied.  Otherwise return false.  */
> +static bool
> +may_have_side_effect_p (tree stmt)

Can you give this function a different name?  It does not seem to test
for whether the statement may have side effects: e.g., statements do
not have side effects merely because they are at the end of a basic
block.  The function seems to test for some other property and I think
it would be clearer if it had some other name.



More information about the Gcc-patches mailing list