[PATCH] The first patch from the fixed-point branch

Richard Sandiford richard@codesourcery.com
Tue Jun 26 13:13:00 GMT 2007


Thanks for all the fixed-point work.  And sorry for replying after
the patch has been committed; I'm still catching up on mail after
a break.

"Fu, Chao-Ying" <fu@mips.com> writes:
> @@ -1293,6 +1403,14 @@
>  @item GET_MODE_BITSIZE (@var{m})
>  Returns the size in bits of a datum of mode @var{m}.
>  
> +@findex GET_MODE_IBIT
> +@item GET_MODE_IBIT (@var{m})
> +Returns the number of integral bits of a datum of fixed-point mode @var{m}.
> +
> +@findex GET_MODE_FBIT
> +@item GET_MODE_FBIT (@var{m})
> +Returns the number of fractional bits of a datum of fixed-point mode @var{m}.
> +

I wonder if GET_MODE_IBITSIZE and GET_MODE_FBITSIZE (or GET_MODE_IBITS
and GET_MODE_FBITS, or GET_MODE_IWIDTH and GET_MODE_FWIDTH) would be
better names?  Based on the names alone, I'd have assumed
GET_MODE_[IF]BIT were bit positions rather than widths.

It might well just be me though.

Richard



More information about the Gcc-patches mailing list