Unrepresentable subregs and hard_regno_nregs

Steven Bosscher stevenb.gcc@gmail.com
Mon Jan 1 23:00:00 GMT 2007


On Monday 01 January 2007 22:44, Joseph S. Myers wrote:
> +      && REGNO (SUBREG_REG (reg)) < FIRST_PSEUDO_REGISTER)

May I suggest using HARD_REGISTER_P instead:

> +      && HARD_REGISTER_P (SUBREG_REG (reg)))

?

I know we check regno < FIRST_PSEUDO_REGISTER almost everywhere
but I'm kinda hoping to convince people that the HARD_REGISTER_P
and HARD_REGISTER_NUM_P checks are more readable... ;-)

Gr.
Steven



More information about the Gcc-patches mailing list