[PATCH] Make gcc/configure* ld version parser a little bit less strict

Jakub Jelinek jakub@redhat.com
Mon Nov 13 19:54:00 GMT 2006


On Fri, Nov 10, 2006 at 04:39:28PM -0500, DJ Delorie wrote:
> > Ok for 4.3/4.2/4.1?
> > 
> > 2006-11-07  Jakub Jelinek  <jakub@redhat.com>
> > 
> > 	* configure.ac (ld_vers): Parse GNU ld version 2.17.50.0.3-6 20060715
> > 	style versions.
> > 	* configure: Rebuilt.
> 
> Ok for HEAD; ok for the others if the release managers say so.

Mark, is this ok also for 4.2/4.1?  It is a regression of a different kind (GCC
4.x configured on FC6 regresses to GCC 4.x configured on FC5 or other
distros) and is IMHO safe (configure really doesn't care about the lower
version numbers anyway, only major/minor and date).

	Jakub



More information about the Gcc-patches mailing list