[patch] ppc64 native target for gcc

Jack Howarth howarth@bromo.msbb.uc.edu
Fri Nov 10 21:16:00 GMT 2006


Brad,
    I could be wrong but I believe that a working libffi is
needed by java to function properly. Currently the libffi
in both gcc trunk and 4.2 branch has not been revised for
64-bit support on Darwin. This explains why so many libffi
and java testsuite failures occur at -m64 on a build with
the powerpc-*-darwin* target. The java build uses the gcj
and other java utilities to complete the libjava build.
Hence this is extremely unlikely to ever work until libffi
gets 64-bit support on Darwin.
              Jack

On Fri, Nov 10, 2006 at 03:11:45PM -0500, Bradley Lucier wrote:
> 
> What do you mean by "pointless"?  Will *no* java programs compile/run  
> on ppc64?
> 



More information about the Gcc-patches mailing list