[RFC/PATCH] Standardize on "for (;;)" for unbounded loops

Richard Kenner kenner@vlsi1.ultra.nyu.edu
Mon Nov 6 22:33:00 GMT 2006

> > [2]	do
> > 	  ...
> > 	while (1);

> I don't care strongly for any of these forms.  They all look equally 
> intuitive to me.  I don't think it's worth forcing one over the other, 
> actually.  But if there's consensus over one particular form, I'll be 
> happy to follow it.

I don't like [2] because it's not obvious until the end of the loop
(which may be many lines down) that it's an infinite loop, but have no
preferences about the other ones.

More information about the Gcc-patches mailing list