3.4 PATCH: Add -mcpu=7400 to Altivec tests

Andrew Pinski pinskia@physics.uc.edu
Fri Mar 25 18:55:00 GMT 2005


On Mar 25, 2005, at 1:34 PM, Mark Mitchell wrote:

>
> It turns out that I was looking at results from an old tree.  In
> 3.4.x, if you configure --with-cpu=603 and then use -maltivec, the
> Altivec extensions are still disabled.  That's been changed in 4.0.
> We wouldn't want to backport that change to 3.4, as it might result in
> silent code changes to user applications, but seeing the test failures
> isn't helpful.  So, for 3.4 only, I checked in this change, which
> ensures that we're building the AltiVec tests for an appropriate CPU.
>
> Thanks to David and Aldy for helping me with this issue.
>
> Tested with a PowerPC GNU/Linux compiler configured --with-cpu=603,
> committed on the 3.4 branch.
>

Are you sure that it was not fixed also on the 3.4 branch too because
I remember the patch which I pointed out was applied there also.

-- Pinski



More information about the Gcc-patches mailing list