PATCH: __nodebug__ attribute for use on SSE intrinsic wrappers

Daniel Berlin dberlin@dberlin.org
Fri Jul 29 21:27:00 GMT 2005


On Fri, 2005-07-29 at 12:57 -0700, Devang Patel wrote:
> On Jul 29, 2005, at 12:52 PM, Daniel Berlin wrote:
> 
> >> But it's not a function!
> >>
> > It's vec_add.
> 
> We've already solved the problem for vec_add. Stuart is referring to  
> "_mm_add_epi8".
> 

So go back and put s/vec_add/_mm_add_epi8/ in my emails :)


BTW, I should probably point out that Intel defines these as functions
too in their compiler (see icc 9.0, emmintrin.h, for example):


/*
 * Integer intrinsics
 */

/****************************************************/
/*  NAME : _mm_add_epi8                             */
/*  DESCRIPTION : Adds 16 unsigned or signed 8-bit  */
/*                integers in a to b                */
/****************************************************/
_MM_INLINE_COMMAND static __m128i _mm_add_epi8(__m128i a, __m128i b)
{
  __m128i ret;
  int i;

  for (i=0; i<16; i++)
        ret.m128i.b[i] = a.m128i.b[i] +  b.m128i.b[i];
  return ret;
}










More information about the Gcc-patches mailing list