Java: Fix PR 1262

Ranjit Mathew rmathew@gmail.com
Tue Jun 29 09:40:00 GMT 2004


[Some minor nits.]

Bryce McKinlay wrote:
>        tree method_sig =
>  	build_java_argument_signature (TREE_TYPE (method_decl));

While you're at it, you might want to correct this minor
formatting error (move "=" on the next line).


> +	  if (! METHOD_PUBLIC (super_method) && 
> +	      ! METHOD_PROTECTED (super_method))

I think our style is to have the logical AND operator on
the next line.


> +	      if (METHOD_PRIVATE (super_method) ||
> +		  ! in_same_package (TYPE_NAME (this_class), 

Likewise.


> +int
> +in_same_package (tree name1, tree name2)

You might want to refactor class_in_current_package() in parse.y
to use this new method. Why duplicate code unnecessarily?
(I know this was there already, so there might have been some
rationale in keeping things this way...)


> +  if (QUALIFIED_P (name1) == 0 && QUALIFIED_P (name2) == 0)

Would "if (! QUALIFIED_P (name1) && ! QUALIFIED_P (name2))" look
better?

> +    /* Both in empty package. */
                               ^^^--- Two spaces.

Ranjit.

-- 
Ranjit Mathew          Email: rmathew AT gmail DOT com

Bangalore, INDIA.      Web: http://ranjitmathew.tripod.com/



More information about the Gcc-patches mailing list