Request for testing on fold-const.c patch

Richard Henderson rth@redhat.com
Tue Jul 27 05:31:00 GMT 2004


On Mon, Jul 26, 2004 at 06:26:48PM -0400, Richard Kenner wrote:
> Seriously, though, I consider this sort of thing far cleaner than the
> alternative approach where you break it up into separate return statements by
> inverting the conditions.

We disagree then.  I much prefer the separate return conditions.
Indeed, I would even split up 

> 	if ((!TREE_OPERAND (arg0, 2) || !TREE_OPERAND (arg1, 2))
>             ? TREE_OPERAND (arg0, 2) != TREE_OPERAND (arg1, 2)
>             : operand_equal_p (TREE_OPERAND (arg0, 2),
>  			       TREE_OPERAND (arg1, 2), flags))
> 	  return 0;

this.

> Since most people look at code on the screen and not on paper, I find that
> being able to put all related code in one screen-full is very important for
> readability and often worth slightly compromising other cleanliness goals
> to accomplish.

I disagree that a screen-full of a single expression is either
readable or clean.


r~



More information about the Gcc-patches mailing list