[PATCH] Do not refer directly to gen_lowpart_xxx

Bonzini bonzini@gnu.org
Thu Jan 29 10:18:00 GMT 2004


> I also think that it is highly confusing that a gen_lowpart call then
> means something different in the combiner than it does anywhere else,
> yet it's identical in the source code.  You might set a breakpoint on
> gen_lowpart and be baffled that it isn't hit.

It is pretty evident that combine uses a different gen_lowpart function:

bonzini@sola3:~/gcc/obj/gcc$ gdb cc1
(gdb) b gen_lowpart
"gen_lowpart" is not a function
(gdb) b gen_lowpart <TAB>
gen_lowpart              gen_lowpart_common       gen_lowpart_general
gen_lowpart_SUBREG       gen_lowpart_for_combine
gen_lowpart_if_possible

I'd love to rename gen_lowpart_if_possible to gen_lowpart_for_cse, but
it is used in integrate.c; maybe this will die after tree-ssa is merged?

Paolo



More information about the Gcc-patches mailing list