[PATCH]: Enable use of AltiVec regs for simd-2.C

Geoff Keating geoffk@desire.geoffk.org
Wed Feb 11 22:23:00 GMT 2004


> X-Original-To: geoffk@foam.wonderslug.com
> Cc: dje <dje@watson.ibm.com>, gcc-patches@gcc.gnu.org,
>         Geoff Keating <geoffk@geoffk.org>,
>         Segher Boessenkool <BOESSEN@de.ibm.com>
> From: Hartmut Penner <HPENNER@de.ibm.com>
> Date: Wed, 11 Feb 2004 16:28:12 +0100
> X-MIMETrack: Serialize by Router on D12ML006/12/M/IBM(Release 6.0.2CF2|July 23, 2003) at
>  11/02/2004 16:28:23
> X-OriginalArrivalTime: 11 Feb 2004 15:28:41.0718 (UTC) FILETIME=[BA9D2960:01C3F0B3]
> 
> 
> 
> 
> 
> > So, on a ppc64-linux system without altivec we can't use vector
> > operations at all?  Not even generic simd code?
> 
> On ppc64-linux the ABI has included AltiVec, what means if you use
> vectors of type V4SI, V4SF, V8HI or V16QI, this mostly needs AltiVec
> instructions (except varargs). All other types may be used by
> generic simd code. In case you want to use types mentioned above,
> you need to compile with -mabi=no-altivec (and generate non ABI
> conform code).

Then you should xfail this test on ppc64-linux.

-- 
- Geoffrey Keating <geoffk@geoffk.org>



More information about the Gcc-patches mailing list