[PATCH]: begin removing size_int_type

Nathan Sidwell nathan@codesourcery.com
Tue Aug 24 14:01:00 GMT 2004


Gabriel Dos Reis wrote:
> Nathan Sidwell <nathan@codesourcery.com> writes:

> Hmm, the naming looks odd to me.  Why not
> 
>   * build_int_cst
>   * build_uint_cst
>   * build_wide_int_cst
because the u applies to the provided value, NOT to the type of the const
being created.

nathan

-- 
Nathan Sidwell    ::   http://www.codesourcery.com   ::     CodeSourcery LLC
nathan@codesourcery.com    ::     http://www.planetfall.pwp.blueyonder.co.uk




More information about the Gcc-patches mailing list