PATCH: [PR preprocessor/16950] [3.5 regression] -Wno-deprecated doesn't work

Zack Weinberg zack@codesourcery.com
Tue Aug 10 06:30:00 GMT 2004


"H. J. Lu" <hjl@lucon.org> writes:

> 2004-08-09  H.J. Lu  <hongjiu.lu@intel.com>
>
> 	* java-tree.h (flag_deprecated): Removed.
>
> 	* lang.opt (Wdeprecated): Use existing Var(warn_deprecated).
>
> 	* parse.y (check_deprecation): Check warn_deprecated instead of
> 	flag_deprecated.

No blank lines, please.

>  Wdeprecated
> -Java Var(flag_deprecated) Init(1)
> -Warn if deprecated class, method, or field is used
> +Java Var(warn_deprecated) VarExists
> +Warn if deprecated compiler feature, class, method, or field is used

Missing article:  "Warn if a deprecated ..."

OK with those changes.

zw



More information about the Gcc-patches mailing list