Richard Henderson
Fri Mar 15 10:36:00 GMT 2002

On Fri, Mar 15, 2002 at 05:10:14PM +0100, Lars Brinkhoff wrote:
> 	* rtl.h (GEN_INT_MODE): New macro.
> 	* combine.c (make_extraction, simplify_comparison), expmed.c
> 	(store_bit_field, expand_mult_highpart, expand_divmod), expr.c
> 	(convert_modes, store_field), optabs.c (expand_fix),
> 	simplify-rtx.c (neg_const_int, simplify_unary_real):
> 	Use it instead of GEN_INT (trunc_int_for_mode (...)).

Ok, except,

> + #define GEN_INT_MODE(N, MODE)  GEN_INT (trunc_int_for_mode ((N), (MODE)))

I'd prefer this to be a function in emit-rtl.c, placed immediately
after gen_rtx_CONST_INT.  There's no sense inlining two function
calls like this.


More information about the Gcc-patches mailing list