[PATCH] C++ space optimization: omit EH info for thunks

Jason Merrill jason@redhat.com
Fri Aug 16 10:39:00 GMT 2002


On Fri, 16 Aug 2002 10:22:38 -0700, Stuart Hastings <stuart@apple.com> wrote:

>      * gcc/gcc/function.h Add 'all_throwers_are_sibcalls' to cfun.
>      * gcc/gcc/except.c (nothrow_function_p) Set it.
>      * gcc/gcc/dwarf2out.c Add 'all_throwers_are_sibcalls' to FDE.
>      (output_call_frame_info) Test it.
>      (dwarf2out_begin_prologue) Propagate it from cfun to FDE.

If you're going to change nothrow_function_p to set a new flag in cfun, it
should set both flags directly rather than set one directly and return the
other.  As a result, it should probably be renamed; perhaps to
"set_nothrow_function_flags".

Jason



More information about the Gcc-patches mailing list