[PATCH] Fix sibcall related failure in g++.old-deja/g++.other/eh1.C

Jeffrey A Law law@cygnus.com
Wed Jun 21 10:54:00 GMT 2000


  In message < 20000616184049.W474@sunsite.ms.mff.cuni.cz >you write:
  > > FWIW, I'd have written it as,
  > > if (insn)
  > >   {
  > >     tree probe;
  > >     
  > >     while ((probe = NEXT_INSN (insn)))
  > >       insn = probe;
  > >     set_last_insn (insn);
  > >   }
  > > 
  > > Which, I find clearer. (maybe a != NULL_TREE should be put in there
  > > for good measure too ...
  > 
  > I wanted to optimize for the common case (ie. insn != NULL_RTX, NEXT_INSN
  > (insn) == NULL_RTX) and avoid calling set_last_insn in that case.
  > But I'm of course open to changing it to be more readable.
Given the initial confusion about the code, I think it is worth trying
to make it more readable.

In general, if people have to ask questions about the code, then the code
either needs to be rewritten or needs additional comments to make the
author's intent clearer.

Jeff



More information about the Gcc-patches mailing list