ranlib, not searched at the right place

Paul Dufresne dufresnep@zoho.com
Fri Jun 18 23:09:49 GMT 2021

---- Le ven., 18 juin 2021 12:20:46 -0400 J.W. Jagersma <jwjagersma@gmail.com> écrit ----

On 2021-06-18 12:43, Paul Dufresne via Gcc-help wrote: 
>> Goal: compile DOS 32 bits program in Linux because many scripts use bash 
>I have a complete toolchain build script on github, you may find it useful: 

Thank you so much!

It worked great... the second time... first time it was complaining my binutils file had premature EOF,

... so I rm -r build, rm download/*, and tried again.

Was able to compile hello.exe, and run it in DOSEMU2.

So I tried to go in my gnu-chess directory:

CC=/home/paul/opt/cross/bin/i386-pc-msdosdjgpp-gcc ./configure --build=i686-pc-linux-gnu --host=i386-pc-msdosdjgpp

maybe the CC stuff was not necessary...

paul@kasparno:~/Téléchargements/gnuchess$ LANG=C make

Making all in src

make[1]: Entering directory '/home/paul/Téléchargements/gnuchess/src'

make  all-recursive

make[2]: Entering directory '/home/paul/Téléchargements/gnuchess/src'

Making all in frontend

make[3]: Entering directory '/home/paul/Téléchargements/gnuchess/src/frontend'

i386-pc-msdosdjgpp-g++ -DHAVE_CONFIG_H -I. -I../../src  -I../../src -I../../lib   -g -O2 -MT atak.o -MD -MP -MF .deps/atak.Tpo -c -o atak.o atak.cc

In file included from atak.cc:30:

common.h:32:10: fatal error: pthread.h: No such file or directory

   32 | #include <pthread.h>

      |          ^~~~~~~~~~~

compilation terminated.

make[3]: *** [Makefile:421: atak.o] Error 1

make[3]: Leaving directory '/home/paul/Téléchargements/gnuchess/src/frontend'

make[2]: *** [Makefile:576: all-recursive] Error 1

make[2]: Leaving directory '/home/paul/Téléchargements/gnuchess/src'

make[1]: *** [Makefile:416: all] Error 2

make[1]: Leaving directory '/home/paul/Téléchargements/gnuchess/src'

make: *** [Makefile:516: all-recursive] Error 1

paul@kasparno:~/Téléchargements/gnuchess$ CC=/home/paul/opt/cross/bin/i386-pc-msdosdjgpp-gcc ./configure --build=i686-pc-linux-gnu --host=i386-pc-msdosdjgpp

So now, all I have to do is figure out how to handle threads in DOS, and I should be able to play chess! [80% joking]

Time for me to take my walk and think a bit...

Thank you again so much!

More information about the Gcc-help mailing list