multiple installed versions of gcc -- automatically set rpath ??

Thomas Doczkal Thomas.Doczkal@socionext.com
Fri May 29 11:02:44 GMT 2020


On 5/29/20 11:28 AM, Patrick Bégou wrote:
> Just load your tailored module (setting PATH, LD_LIBRARY_PATH....) to
> activate the gcc version needed and compile/execute

While setting LD_LIBRARY_PATH in modules is possible I see this with a
grain of salt. It's tricky if you load two or more modules in the same
shell.

For what it's worth we change the rpath of the dynamically linked
binaries with patchelf where possible.

Regards
Thomas


-- 
Thomas Doczkal
Snr System Engineer


Socionext Europe GmbH
pittlerstrasse 47
63225 langen, germany
tel +49-6103-3745-386
mobile +49-174-9226082
fax +49-6103-3745-122
thomas.doczkal@socionext.com
www.eu.socionext.com
www.socionext.com

Geschaeftsfuehrer/Managing Director: Toshihiko Tanaka, Dirk Weinsziehr,
Koichi Otsuki, Yutaka Yoneyama

Sitz/Seat: Langen, Hessen; Registergericht/Commercial Register:
Offenbach/Main HRB 48005


This e-mail and any attachment contains information
which is private and confidential and is intended for
the addressee only. If you are not an addressee, you
are not authorized to read, copy or use the e-mail or
any attachment. If you have received this e-mail in
error, please notify the sender by return e-mail and
then delete it.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 5154 bytes
Desc: S/MIME Cryptographic Signature
URL: <https://gcc.gnu.org/pipermail/gcc-help/attachments/20200529/e572e3de/attachment.p7s>


More information about the Gcc-help mailing list