exec: -m: invalid option for GCC 9.2.0 on RHEL6.9

Thomas Doczkal Thomas.Doczkal@socionext.com
Tue Dec 3 12:39:00 GMT 2019


Hi,

I want to compile GCC 9.2.0 on RHEL 6.9.

The compile exits with the following error log:

parts="crtbegin.o crtbeginS.o crtbeginT.o crtend.o crtendS.o crtprec32.o
crtprec64.o crtprec80.o
crtfastmath.o";                                        \
        for file in $parts; do                                  \
          rm -f ../.././gcc/$file;              \
          /usr/bin/install -c -m 644 $file ../.././gcc/;        \
          case $file in                                         \
            *.a)                                                \
              ranlib ../.././gcc/$file ;;       \
          esac;                                                 \
        done
# @multilib_flags@ is still needed because this may use
# /fme/app/.build/gcc/gcc-9.2.0/build/./gcc/xgcc
-B/fme/app/.build/gcc/gcc-9.2.0/build/./gcc/
-B/fme/app/gcc/9.2.0/x86_64-pc-linux-gnu/bin/
-B/fme/app/gcc/9.2.0/x86_64-pc-linux-gnu/lib/ -isystem
/fme/app/gcc/9.2.0/x86_64-pc-linux-gnu/include -isystem
/fme/app/gcc/9.2.0/x86_64-pc-linux-gnu/sys-include   -fno-checking and
-O2  -g -O2 -DIN_GCC    -W -Wall -Wno-narrowing -Wwrite-strings
-Wcast-qual -Wno-format -Wstrict-prototypes -Wmissing-prototypes
-Wold-style-definition  -isystem ./include   -fpic -mlong-double-80
-DUSE_ELF_SYMVER  -g -DIN_LIBGCC2 -fbuilding-libgcc
-fno-stack-protector  directly.
# @multilib_dir@ is not really necessary, but sometimes it has
# more uses than just a directory name.
/bin/sh ../../../libgcc/../mkinstalldirs .
/fme/app/.build/gcc/gcc-9.2.0/build/./gcc/xgcc
-B/fme/app/.build/gcc/gcc-9.2.0/build/./gcc/
-B/fme/app/gcc/9.2.0/x86_64-pc-linux-gnu/bin/
-B/fme/app/gcc/9.2.0/x86_64-pc-linux-gnu/lib/ -isystem
/fme/app/gcc/9.2.0/x86_64-pc-linux-gnu/include -isystem
/fme/app/gcc/9.2.0/x86_64-pc-linux-gnu/sys-include   -fno-checking -O2 
-g -O2 -DIN_GCC    -W -Wall -Wno-narrowing -Wwrite-strings -Wcast-qual
-Wno-format -Wstrict-prototypes -Wmissing-prototypes
-Wold-style-definition  -isystem ./include   -fpic -mlong-double-80
-DUSE_ELF_SYMVER  -g -DIN_LIBGCC2 -fbuilding-libgcc
-fno-stack-protector  -shared -nodefaultlibs -Wl,--soname=libgcc_s.so.1
-Wl,--version-script=libgcc.map -o ./libgcc_s.so.1.tmp -g -O2 -B./
_muldi3_s.o _negdi2_s.o _lshrdi3_s.o _ashldi3_s.o _ashrdi3_s.o
_cmpdi2_s.o _ucmpdi2_s.o _clear_cache_s.o _trampoline_s.o __main_s.o
_absvsi2_s.o _absvdi2_s.o _addvsi3_s.o _addvdi3_s.o _subvsi3_s.o
_subvdi3_s.o _mulvsi3_s.o _mulvdi3_s.o _negvsi2_s.o _negvdi2_s.o
_ctors_s.o _ffssi2_s.o _ffsdi2_s.o _clz_s.o _clzsi2_s.o _clzdi2_s.o
_ctzsi2_s.o _ctzdi2_s.o _popcount_tab_s.o _popcountsi2_s.o
_popcountdi2_s.o _paritysi2_s.o _paritydi2_s.o _powisf2_s.o _powidf2_s.o
_powixf2_s.o _mulhc3_s.o _mulsc3_s.o _muldc3_s.o _mulxc3_s.o _divhc3_s.o
_divsc3_s.o _divdc3_s.o _divxc3_s.o _bswapsi2_s.o _bswapdi2_s.o
_clrsbsi2_s.o _clrsbdi2_s.o _fixunssfsi_s.o _fixunsdfsi_s.o
_fixunsxfsi_s.o _fixsfdi_s.o _fixdfdi_s.o _fixxfdi_s.o _fixunssfdi_s.o
_fixunsdfdi_s.o _fixunsxfdi_s.o _floatdisf_s.o _floatdidf_s.o
_floatdixf_s.o _floatundisf_s.o _floatundidf_s.o _floatundixf_s.o
_divdi3_s.o _moddi3_s.o _divmoddi4_s.o _udivdi3_s.o _umoddi3_s.o
_udivmoddi4_s.o _udiv_w_sdiv_s.o cpuinfo_s.o sfp-exceptions_s.o
addtf3_s.o divtf3_s.o multf3_s.o negtf2_s.o subtf3_s.o unordtf2_s.o
fixtfsi_s.o fixunstfsi_s.o floatsitf_s.o floatunsitf_s.o fixtfdi_s.o
fixunstfdi_s.o floatditf_s.o floatunditf_s.o fixtfti_s.o fixunstfti_s.o
floattitf_s.o floatuntitf_s.o extendsftf2_s.o extenddftf2_s.o
extendxftf2_s.o trunctfsf2_s.o trunctfdf2_s.o trunctfxf2_s.o getf2_s.o
letf2_s.o eqtf2_s.o _divtc3_s.o _multc3_s.o _powitf2_s.o
enable-execute-stack_s.o unwind-dw2_s.o unwind-dw2-fde-dip_s.o
unwind-sjlj_s.o unwind-c_s.o emutls_s.o libgcc.a -lc && rm -f
./libgcc_s.so && if [ -f ./libgcc_s.so.1 ]; then mv -f ./libgcc_s.so.1
./libgcc_s.so.1.backup; else true; fi && mv ./libgcc_s.so.1.tmp
./libgcc_s.so.1 && (echo "/* GNU ld script"; echo "   Use the shared
library, but some functions are only in"; echo "   the static library. 
*/"; echo "GROUP ( libgcc_s.so.1 -lgcc )" ) > ./libgcc_s.so
/fme/app/.build/gcc/gcc-9.2.0/build/./gcc/collect-ld: line 106: exec:
-m: invalid option
exec: usage: exec [-cl] [-a name] [command [arguments ...]] [redirection
...]
collect2: error: ld returned 2 exit status
make[3]: *** [libgcc_s.so] Error 1
make[3]: Leaving directory
`/fme/app/.build/gcc/gcc-9.2.0/build/x86_64-pc-linux-gnu/libgcc'
make[2]: *** [all-stage1-target-libgcc] Error 2
make[2]: Leaving directory `/fme/app/.build/gcc/gcc-9.2.0/build'
make[1]: *** [stage1-bubble] Error 2
make[1]: Leaving directory `/fme/app/.build/gcc/gcc-9.2.0/build'
make: *** [all] Error 2
make[1]: Entering directory `/fme/app/.build/gcc/gcc-9.2.0/build'
/bin/sh ../mkinstalldirs /fme/app/gcc/9.2.0 /fme/app/gcc/9.2.0
make[2]: Entering directory
`/fme/app/.build/gcc/gcc-9.2.0/build/fixincludes'
make[2]: *** No rule to make target `install'.  Stop.
make[2]: Leaving directory `/fme/app/.build/gcc/gcc-9.2.0/build/fixincludes'
make[1]: *** [install-fixincludes] Error 2
make[1]: Leaving directory `/fme/app/.build/gcc/gcc-9.2.0/build'
make: *** [install] Error 2

Most relevant line is probably this one:

> /fme/app/.build/gcc/gcc-9.2.0/build/./gcc/collect-ld: line 106: exec:
-m: invalid option

line 106 is the following

> exec $original ${1+"$@"}

The error is the same if I build in the source directory or in a
separate build directory. I also tried to use a different gcc (8.2.0)
where the compile works fine AFAIK to compile 9.2.0 with the same error.

Can someone confirm the error or tell what's wrong?

Thanks,

Thomas

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 5154 bytes
Desc: S/MIME Cryptographic Signature
URL: <https://gcc.gnu.org/pipermail/gcc-help/attachments/20191203/2412784b/attachment.p7s>


More information about the Gcc-help mailing list