gcc version 4.8.5 20150623 / Meltdown and/or Spectre vulnerabilities

Jeff Law law@redhat.com
Fri Jun 15 15:22:00 GMT 2018


On 06/15/2018 08:58 AM, Xi Ruoyao wrote:
> On 2018-06-15 17:42 +0300, Vassilena Treneva wrote:
>> Hey,
>>
>> Using gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC).
>>
>> Do you know if there are any compiler options (or a patch) to mitigate the
>> so called: Meltdown and/or Spectre vulnerabilities for this specific
>> version of the compiler?
>> Based on what I read over the internet, the answer is NO. Such options and
>> a patch are available starting from GCC 8:
>> https://gcc.gnu.org/ml/gcc-patches/2018-01/msg00422.html
> 
> The compiler has nothing to do with Meltdown and Spectre v1.  For Spectre v2
> GCC 8.1 and 7.3 have -mindirect-branch option.
> 
> GCC 4.8 is no longer supported by GCC team.  Maybe Red Hat could backport
> this patch for you.
Red Hat has already backported ported the spectre v2 mitigations to its
gcc-4.8 compilers for RHEL 7, its gcc-4.4 compilers for RHEL 6 and its
gcc-4.1 compilers for RHEL 5.

These compilers (and kernels which use those mitigations) are available
via the usual channels.

jeff



More information about the Gcc-help mailing list