gcc-5.2: error :Checking multilib configuration for libgomp...

Jonathan Wakely jwakely.gcc@gmail.com
Fri Nov 20 11:41:00 GMT 2015

On 20 November 2015 at 10:09, Luis wrote:
> Okay, I've tried from /gpfs/home/HCBG142/axs02/lxc83-axs02/gcc-5.2.0/build:
> ../configure --build=powerpc64-bgq-linux-gnu --host=powerpc64-bgq-linux
> --prefix=/gpfs/home/HCBG142/axs02/lxc83-axs02/gcc5
> --with-gmp=/gpfs/home/HCBG142/axs02/lxc83-axs02/aux/gmp
> --with-mpfr=/gpfs/home/HCBG142/axs02/lxc83-axs02/aux/mpfr
> --with-mpc=/gpfs/home/HCBG142/axs02/lxc83-axs02/aux/mpc

You're making life difficult for yourself by using --with-gmp and
--with-mpfr and --with-mpc, it is much easier to put the sources for
those libraries in the GCC source tree and let GCC build them

See https://gcc.gnu.org/wiki/InstallingGCC and the script

> and make reports the same error:
> Markus, I assume that --disable-libgomp disables OpenMP and that is not
> an option, I need OpenMP.
> The config.log under libgomp shows this error:
> configure:3657:
> /gpfs/home/HCBG142/axs02/lxc83-axs02/gcc-5.2.0/build-up/./gcc/\
> xgcc -B/gpfs/home/HCBG142/axs02/lxc83-axs02/gcc-5.2.0/build-up/./gcc/
> -B/gpfs/\
> home/HCBG142/axs02/lxc83-axs02/gcc5/powerpc64-bgq-linux/bin/
> -B/gpfs/home/HCBG\
> 142/axs02/lxc83-axs02/gcc5/powerpc64-bgq-linux/lib/ -isystem
> /gpfs/home/HCBG14\
> 2/axs02/lxc83-axs02/gcc5/powerpc64-bgq-linux/include -isystem
> /gpfs/home/HCBG1\
> 42/axs02/lxc83-axs02/gcc5/powerpc64-bgq-linux/sys-include    -V >&5
> xgcc: error: unrecognized command line option '-V'
> xgcc: fatal error: no input files
> compilation terminated.

That error is expected, you need to look at the rest of the file for
the error that causes the problem.

More information about the Gcc-help mailing list