GCCG with C++11

Brian Budge brian.budge@gmail.com
Thu May 28 15:31:00 GMT 2015


I googled and found this:

#if __cplusplus <= 199711L
  #error This library needs at least a C++11 compliant compiler
#endif


On Thu, May 28, 2015 at 8:24 AM, Hotmail (ArbolOne) <ArbolOne@hotmail.ca> wrote:
> If I am not mistaken _MSC_VER >= 1600 is the version that started
> implementing C++11. So, I test for that version of the compiler in my code,
> i.e.
> #ifdef _MSC_VER >= 1600
>    ....
> #endif
> I would like to do the same for __GNUG__, but what version of g++ started
> implementing C++11?
>
> Thanks



More information about the Gcc-help mailing list