Test Error on GMP6.0.0.a

Marc Glisse marc.glisse@inria.fr
Sun May 3 19:30:00 GMT 2015


On Sun, 3 May 2015, Henning Thedens wrote:

> On my System (Ubuntu14.04 on an Intel Sandy-bridge) gcc 4.9.2 builds gmp 6.0.0.a fine with -flto -fuse-linker-plugin as CFLAGS, but testing gives the following error:
>
>  
> mpz_get_d_2exp wrong on 2**54-1
> result out of range, expect 0.5 <= got < 1.0
>    rnd_mode = 0
>    data[i]  = 54
>    z    =0x3FFFFFFFFFFFFF
>    got  =[00 00 00 00 00 00 F0 3F] 1
>    got exp  54
>  
> Adding -ffat-lto-objects to the flags, testing gives no errors.
> Is this an gcc problem?
> There was an discussion on gmplib.org about this error on GMP 5.1 using Clang, but i did not figure out whether there was any resolution.

I assume you are talking about this thread?
https://gmplib.org/list-archives/gmp-bugs/2013-August/003115.html

But the following posts say quite clearly that the issues are in GMP, not 
in the compilers (so this is the wrong list). I don't think it was fixed, 
but you could download a snapshot from gmplib.org and test it.

-- 
Marc Glisse



More information about the Gcc-help mailing list