dwarf2 problem in gcc-4.9.2

Jonathan Wakely jwakely.gcc@gmail.com
Tue Dec 1 13:31:00 GMT 2015


On 1 December 2015 at 06:31, vikram1729 wrote:
> hi all
>
> i am trying to port gcc-4.9.2 to a custom processor. i got following error
> while compiling glibc
>
>
> 'found dwarf version 4 but this reader handles only 2 or 3'
>
> linker is complaining this
> my binutils version is 2.19.

If you can't upgrade binutils then you can compile with -gdwarf-3 to
prevent GCC outputting DWARF v4 data.

If you still get problems then use -gdwarf-3 -gstrict-dwarf



More information about the Gcc-help mailing list