Building gcc with gmp source is failing with "Can't find gmp headers" (Centos 6.5)

Manuel López-Ibáñez lopezibanez@gmail.com
Mon Apr 14 11:17:00 GMT 2014


On 14 April 2014 12:52, Dave Gittins <dave.gittins@gmail.com> wrote:
> On Mon, Apr 14, 2014 at 5:19 PM, Marc Glisse <marc.glisse@inria.fr> wrote:
>> AFAIK they are requirements for the not-yet-released 4.9.0. Requirements
>> change for each release, you need to find some in the specific 4.4.0
>> documentation.
>
> On Mon, Apr 14, 2014 at 7:34 PM, Chung-Ju Wu <jasonwucj@gmail.com> wrote:
>> The ISL is used after gcc-4.8.
>>
>> From the gcc-4.4.0 souce, gcc/doc/install.text,
>> the prerequisites are:
>>   gmp 4.1
>>   mpfr 2.3.2
>>   ppl 0.10
>>   cloog-ppl 0.15
>>
>> Also, if I remember correctly, the in-tree build of ppl and cloog-ppl
>> didn't work very well.  So if your are forced to build gcc-4.4.0, either
>> dropping ppl/cloog-ppl or build them by your own with required version.
>
> Thanks guys, makes sense.
>
> So... I tried again with GMP 4.1.1 and MPFR 2.3.2 (dropped PPL and CLooG).
>
> Now it fails with this:
>
> In file included from /usr/include/features.h:385,
>                  from /usr/include/stdio.h:28,
>                  from ../../../../gcc-4.4.0-src/libgcc/../gcc/tsystem.h:87,
>                  from ../../../../gcc-4.4.0-src/libgcc/../gcc/libgcc2.c:29:
> /usr/include/gnu/stubs.h:7:27: error: gnu/stubs-32.h: No such file or directory
>
> Is this progress?!
>
> D

http://gcc.gnu.org/wiki/FAQ#gnu_stubs-32.h



More information about the Gcc-help mailing list